[Orca-dev] [PATCH] Updates to include additional Solaris performancemetrics for graphing
Blair Zajac
blair at orcaware.com
Thu Dec 19 13:38:01 PST 2002
Sean O'Neill wrote:
>
> At 07:58 PM 12/18/2002 -0800, Blair Zajac wrote:
>
> >Hi Sean,
> >
> >Could you do me a favor. The patch you sent got munged somewhere along
> >the way (line wrapping) and I've also applied Liston's patch to orcallator.se
> >and orcallator.cfg.in.
> >
> >Could you update your Orca working copy (with your modifications in it)
> >to HEAD and the latest 'svn diff' output as an attachment. That way it
> >should be better protected.
>
> K svn repos updated to HEAD (rev172 at the time) with my updates merged
> in. HEAD-svn.diff is file attachment with svn diff output.
Hi Sean,
Thanks. This one applied cleanly.
Do you have sample plots for these? I'd like to add them to the
http://www.orcaware.com/orca/docs/orcallator.html
page. This will then let us use href elements for the new plots so
people can get more information on it.
Rather lengthy review below.
Also, please include the log message with any diffs. It makes it
easier to have the entire patch and log message in one email,
rather than finding the old email with the log message.
Regarding the new measurements, let's have all measurements that
are something per second have a "/s" in the name. I haven't looked
closely at which ones are, but I may note some below.
I definitely want to get these new column names right so we don't
have to change them later and mess up plots.
In orcallator.cfg.in:
plot {
+title %g Interrupts, System Calls, Traps
+source orcallator
+data interrupts
+data intrthread
+data system_calls
+data trap
How about we rename 'trap' to 'traps'.
Are these per second?
+legend Interrupts/s
+legend ThreadInterrupts/s
+legend ThreadInterrupts/s
Missing spaces here in these legends.
+title %g Forks, Vforks, & Execs
There's an extra , before the &.
+data forks
+data vforks
+data execs
...
+legend forks/s
+legend vforks/s
+legend execs/s
Is this data is already per second, or the total number in a measured
interval?
+legend Voluntary Switches/s
+legend Involuntary Switches/s
+legend Total
Same here, /s or not.
+title %g namei/s, iget/s, dirblk/s
Can we make this title more useful? I don't know what these mean
without looking them up.
+title %g Pageins/s, Pageouts/s, PagesFreed/s
How about "Pageins/s, Pageouts/s & PagesFreed/s"
+data pgin
+data pgout
+data dfree
/s or not???
+title %g Pages PagedIn/s & Pages PagedOut/s
How does this data set differ from the Pageins/s, Pageouts/s,
PagesFreed/s in the previous plot?
+title %g Major & Minor & Protection Page Faults
Change to "%g Major, Minor & Protection Page Faults"
These also look like per second.
+title %g COW & ZFOD Page Faults
Can we make this longer "Copy-on-write & Zero-fill-on-demand page
Faults"?
I noticed in orcallator.se that ufsinopage is measured, but there's
no plot for it.
Now in orcallator.se:
+// Version 1.37: Dec 20, 2002 Additions by Sean O'Neill - Happy Holidays !!
+// Added several new variables for Orca to collect
+// and graph including:
+// pgrec - page reclaims (include pageout)
+// pgfrec - page reclaims from free list
Anal, but can the list of names be justified as all the other comments are?
+// ufsinopage - inodes taked with no attached pages
Typo on taked?
In lib/Makefile.in and ./orcallator/start_orcallator.sh.in, how
about we put the 3.2.1 and 3.3 directories in a SE directory,
so it looks like
lib/SE/3.2.1
lib/SE/3.3
and that it installs this way also.
Regarding ./lib/Orca/Constants.pm, I'd like to keep this change out of
this patch. How do the output PNG files look with this change?
One of the things that these numbers are designed for is that the number
of data points in a plot is less than the number of pixels in a plot,
otherwise RRD needs to resample the data, and this change from 1.5
days to 3 days bumps the number of data points from 432 to 864, which
is greater than the default width of 500.
Best,
Blair
--
Blair Zajac <blair at orcaware.com>
Plots of your system's performance - http://www.orcaware.com/orca/
More information about the Orca-dev
mailing list